source: spip-zone/_plugins_/top_bando/plugin.xml @ 36736

Last change on this file since 36736 was 36736, checked in by gilles.vincent@…, 11 years ago

Documentation au format PHPDoc
+ indentation
+ suppression des accents des commentaires pour les fichiers qui ne sont pas en utf8

File size: 1.9 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<plugin>
3    <nom>Top bandeau</nom>
4    <auteur>cy_altern
5_ &#169; 2010 - Distribu&#233; sous licence GPL
6    </auteur>
7    <lien></lien>
8    <icon></icon>
9    <version>0.1</version>
10    <etat>dev</etat>
11    <description>
12Ce plugin permet de g&#233;rer le bandeau de sommet des pages: hauteur et images.
13
14Les 2 images utilis&#233;es sont &#224; t&#233;l&#233;charger comme {{logo du site}} et {{logo de survol}}:
15(cf [la page de configuration du site->?exec=configuration])
16-* l'image charg&#232;e comme {{logo de ce site}} (= {{logo}} pour la suite) sera utilis&#232; comme image clicable pour revenir &#224; l'accueil du site.
17Par d&#233;faut elle est align&#233;e &#224; gauche. Elle sera redimensionn&#233;e pour que sa {{hauteur}} soit &#233;gale &#224; celle du bandeau.
18-* l'image charg&#232;e comme {{logo pour survol}} (= {{bandeau}} pour la suite) sera utilis&#233; comme image de fond du bandeau. Elle sera {{recadr&#233;e}}
19selon les param&#232;tres d&#233;finis dans [l'interface de configuration->?exec=cfg&amp;cfg=top_bando] de ce plugin.
20    </description>
21    <prefix>top_bando</prefix>
22    <pipeline>
23        <nom>header_prive</nom>
24        <action>header_prive</action>
25        <inclure>top_bando_pipelines.php</inclure>
26    </pipeline>
27    <fonctions>top_bando_fonctions.php</fonctions>
28    <necessite id="SPIP" version="[2.0.1;]" />
29    <necessite id="cfg" version="[1.10.2;]" />
30    <necessite id='spip_bonux' version='[1.8;]' />
31    <!-- pour utiliser ce plugin en SPIP version 2.0.*   -->
32    <necessite id="lib:jquery.ui-1.6" src="http://jquery-ui.googlecode.com/files/jquery.ui-1.6.zip" />
33    <!-- pour utiliser ce plugin en SPIP version 2.1 -->
34    <necessite id="lib:jquery-ui-1.7.2" src="http://jquery-ui.googlecode.com/files/jquery-ui-1.7.2.zip" />
35
36    <utilise id="palette" version="[1.0;]" />
37    <utilise id="choix_police" version="[0.1;]" />
38    <chemin dir='' />
39</plugin>
Note: See TracBrowser for help on using the repository browser.