source: spip-zone/_plugins_/top_bando/top_bando_pipelines.php @ 47799

Last change on this file since 47799 was 47799, checked in by cy_altern@…, 10 years ago

passage a l'utilisation du plugin jQueryUI pour gerer les differentes version de jQuery en fonction des versions de SPIP

  • Property svn:keywords set to Id
File size: 901 bytes
Line 
1<?php
2/**
3 * Ce plugin permet de g&#233;rer le bandeau de sommet des pages: hauteur et images.
4 *
5 * @author     cy_altern
6 * @license    GNU/GPL
7 * @package    plugins
8 * @subpackage top_bando
9 * @category   Interface Privee
10 * @version    $Id: top_bando_pipelines.php 47799 2011-05-14 19:03:52Z cy_altern@yahoo.fr $
11 */
12
13/**
14 * fonction top_bando_jqueryui_forcer()
15 * utiliser l'API du plugin jqueryUI pour charger js et css des UI
16 * inseres dans le head des pages privees et publiques par le pipeline jqueryui_forcer
17 *
18 * @param string $scripts la liste des UI a charger
19 * @return $scripts
20 */
21function top_bando_jqueryui_forcer($scripts) {
22        $version = substr($GLOBALS['spip_version_affichee'], 0, 3);
23        if ( $version == '2.1') {
24                $scripts[] = "jquery.ui.resizable";
25                $scripts[] = "jquery.ui.draggable";
26        }
27        elseif ($version == '2.0') {
28                $scripts[] = "ui.resizable";
29                $scripts[] = "ui.draggable";
30        }
31               
32        return $scripts;
33}
34       
35
36?>
Note: See TracBrowser for help on using the repository browser.