source: spip-zone/_plugins_/varnish/varnish_install.php @ 46920

Last change on this file since 46920 was 46920, checked in by fil@…, 10 years ago

verifier la config finemeent plutot qu'utiliser necessite= ; mais je ne devrais pas me brancher sur la fonction d'install, car ca ajoute un bouton de desinstall, ici non pertinent

File size: 565 bytes
Line 
1<?php
2
3/* verifier le besoin d'installer statjs et le signaler */
4function varnish_install($test) {
5        if ($GLOBALS['meta']['activer_statistiques'] == 'oui') {
6                $plugins = unserialize($GLOBALS['meta']['plugin']);
7
8                if (!isset($plugins['STATSJS'])) {
9                        include_spip('inc/presentation');
10                        echo debut_boite_info(true);
11                        echo $deja = _L("Pour utiliser les statistiques de SPIP avec Varnish, il est recommandé d'installer le plugin <a href='http://www.spip-contrib.net/3753' class='spip_out'>StatsJS</a>.");
12                        echo fin_boite_info(true);
13                }
14        }
15        return true;
16}
17
18?>
Note: See TracBrowser for help on using the repository browser.