Changeset 117930 in spip-zone


Ignore:
Timestamp:
Sep 24, 2019, 8:52:48 AM (13 months ago)
Author:
maieul@…
Message:

fix : spip_version() pas tjr dispo + perf

Location:
_plugins_/saisies/trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/saisies/trunk/paquet.xml

    r117916 r117930  
    22        prefix="saisies"
    33        categorie="outil"
    4         version="3.28.2"
     4        version="3.28.3"
    55        etat="stable"
    66        compatibilite="[3.0.0;3.2.*]"
  • _plugins_/saisies/trunk/saisies_options.php

    r117916 r117930  
    3434                if (is_string($valeur) and !intval($valeur)) {
    3535                        // Si on a dépassé 3.2, on peut uniquement utilser typo() car ça extrait les <:chaine:>
    36                         if (spip_version_compare(spip_version(), '3.2', '>=')) {
     36                        $version = explode('.',$GLOBALS['spip_version_branche']);
     37                        if ($version[0] > 3 or ($version[1] >= 2 and $version[0] == 3)) {
    3738                                if (
    3839                                        $mode_typo == 'toujours'
Note: See TracChangeset for help on using the changeset viewer.