Changeset 119726 in spip-zone


Ignore:
Timestamp:
Jan 11, 2020, 8:28:19 AM (10 months ago)
Author:
Maïeul Rouquette
Message:

SPIP 3.0 n'est plus supporté. On passe donc en compat spip 3.1 minimum , ce qui permet d'utiliser recuperer_url, de faire une requete HEAD plutot que GET, pour vérifier que le fichier est inaccessible

Location:
_plugins_/formidable/trunk
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/formidable/trunk

    • Property subgit:lock:e0d97874b399c56dbba753a68828f53af900fa06 deleted
    • Property subgit:lock:133811c1cd0afc7baf966bc743d268bf0aae85b5 set to 2020-01-11T09:30:18.763
  • _plugins_/formidable/trunk/inc/formidable_fichiers.php

    r118544 r119726  
    9090        include_spip('inc/distant');
    9191        $url = url_absolue($fichier);
    92         if ($data = recuperer_page($url) && $data != null) {
     92        $data = recuperer_url($url, array(
     93                'methode' => 'HEAD'
     94        ));
     95        if ($data and $data['status'] == 200) {
    9396                // si on peut récuperer la page avec un statut http 200,
    94                 // c'est qu'il y a un problème. recuperer_page() est obsolète en 3.1, mais recuperer_url() n'existe pas en 3.0
    9597                spip_log("$nom_dossier accessible en lecture depuis le web", 'formidable'._LOG_CRITIQUE);
    9698                return _T(
  • _plugins_/formidable/trunk/paquet.xml

    r119670 r119726  
    22        prefix="formidable"
    33        categorie="communication"
    4         version="3.48.0"
     4        version="3.49.0"
    55        etat="stable"
    6         compatibilite="[3.0.0;3.2.*]"
     6        compatibilite="[3.1.0;3.2.*]"
    77        logo="images/formidable-64.png"
    88        schema="0.17.1"
Note: See TracChangeset for help on using the changeset viewer.