Changeset 37400 in spip-zone


Ignore:
Timestamp:
Apr 18, 2010, 11:16:19 AM (10 years ago)
Author:
marcimat@…
Message:

Pétouilles oubliées évidemment :)

Location:
_plugins_/step
Files:
6 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/step/formulaires/step_actions.html

    r34251 r37400  
    66        </div>]
    77
    8         [<div class="reponse_formulaire">(#ENV**{erreurs}|table_valeur{actionneur_actions})</div>]
     8        [<div class="reponse_formulaire reponse_formulaire_actions">(#ENV**{erreurs}|table_valeur{actionneur_actions})</div>]
    99       
    1010        <form method='post' action='#ENV{action}'[ class="(#ENV{gogogo}|>{0}|?{ok})"]><div>
  • _plugins_/step/inc/step.php

    r34251 r37400  
    55define('_FILE_PLUGIN_CONFIG', "plugin.xml");
    66
    7 
     7include_spip('inc/plugin'); // pour spip_version_compare()
     8                               
    89// ---------------------- LIBS -------------------------------
    910
     
    210211                                               
    211212                                                // si version <= moi et etat <= moi, on invalide ce plugin
    212                                                 if (version_compare($r['version'],$insert['version'],'<=') and ($r['etatnum'] <= $insert['etatnum'])) {
     213                                                if (spip_version_compare($r['version'],$insert['version'],'<=') and ($r['etatnum'] <= $insert['etatnum'])) {
    213214                                                        $invalides[] = $r['id_plugin'];
    214215                                                }
    215216                                                if ($insert['actif'] != 'oui') {
    216217                                                        // s'il existe un plugin en tout point mieux, je m'invalide
    217                                                         if ((version_compare($r['version'],$insert['version'],'>') and ($r['etatnum'] >= $insert['etatnum']))
    218                                                         or  (version_compare($r['version'],$insert['version'],'>=') and ($r['etatnum'] > $insert['etatnum']))
     218                                                        if ((spip_version_compare($r['version'],$insert['version'],'>') and ($r['etatnum'] >= $insert['etatnum']))
     219                                                        or  (spip_version_compare($r['version'],$insert['version'],'>=') and ($r['etatnum'] > $insert['etatnum']))
    219220                                                        ) {
    220221                                                                $insert['obsolete'] = 'oui';
     
    238239                                                // si version superieure et etat identique ou meilleur,
    239240                                                // c'est que c'est une mise a jour possible !
    240                                                 if (version_compare($r['version'],$insert['version'],'>')) {
    241                                                         if (!$insert['maj_version'] or version_compare($r['version'], $insert['maj_version'],'>')) {
     241                                                if (spip_version_compare($r['version'],$insert['version'],'>')) {
     242                                                        if (!$insert['maj_version'] or spip_version_compare($r['version'], $insert['maj_version'],'>')) {
    242243                                                                $insert['maj_version'] = $r['version'];
    243244                                                        }
     
    304305                                                //     + on supprime les distants plus vieux
    305306                                                // - plus ancien : on le met pas...
    306                                                 if (version_compare($insert['version'], $r['version'],'>')) {
     307                                                if (spip_version_compare($insert['version'], $r['version'],'>')) {
    307308                                                        $add = true;
    308309                                                        if ($r['id_zone'] == 0) {
     
    402403        #var_dump("$mineure_inc-$mineure-$majeure-$majeure_inc");
    403404        if (strlen($mineure)){
    404                 if ($mineure_inc AND version_compare($version,$mineure,'<')) return false;
    405                 if (!$mineure_inc AND version_compare($version,$mineure,'<=')) return false;
     405                if ($mineure_inc AND spip_version_compare($version,$mineure,'<')) return false;
     406                if (!$mineure_inc AND spip_version_compare($version,$mineure,'<=')) return false;
    406407        }
    407408        if (strlen($majeure)){
    408                 if ($majeure_inc AND version_compare($version,$majeure,'>')) return false;
    409                 if (!$majeure_inc AND version_compare($version,$majeure,'>=')) return false;
     409                if ($majeure_inc AND spip_version_compare($version,$majeure,'>')) return false;
     410                if (!$majeure_inc AND spip_version_compare($version,$majeure,'>=')) return false;
    410411        }
    411412        return true;
  • _plugins_/step/inc/step_actionneur.php

    r34526 r37400  
    397397                        include_spip('inc/plugin');
    398398                        $dossier = rtrim($i['dossier'],'/');
    399                         $infos = plugin_get_infos($dossier);
     399                        $plugin_get_infos = charger_fonction('get_infos', 'plugins');
     400                        $infos = $plugin_get_infos($dossier);
    400401                        if (isset($infos['install'])){
    401402                                // desinstaller
     
    577578
    578579        function installe_plugin($dossier){
    579                 $infos = plugin_get_infos($dossier);
     580                $plugin_get_infos = charger_fonction('get_infos', 'plugins');
     581                $infos = $plugin_get_infos($dossier);
    580582                if (isset($infos['install'])) {
    581583                        if (installe_un_plugin($dossier, $infos)) {
  • _plugins_/step/inc/step_decideur.php

    r34255 r37400  
    11<?php
     2
     3include_spip('inc/plugin'); // pour spip_version_compare()
    24
    35class Decideur {
     
    114116                if ($news and count($news['p'][$prefixe]) > 0) {
    115117                        foreach ($news['p'][$prefixe] as $new) {
    116                                 if (version_compare($new['v'],$version,'>')) {
     118                                if (spip_version_compare($new['v'],$version,'>')) {
    117119                                        if (!$res or version_compare($new['v'],$res['v'],'>')) {
    118120                                                $res = $new;
  • _plugins_/step/plugin.xml

    r37399 r37400  
    88        <licence>GPL</licence>
    99        <lien></lien>
    10         <version>0.10.0</version>
     10        <version>0.10.1</version>
    1111        <version_base>0.4</version_base>
    1212        <install>base/step_install.php</install>
  • _plugins_/step/prive/style_prive_plugin_step.html

    r34251 r37400  
    153153.formulaire_step_actions ul {margin:1em 1em 1em 3em; list-style-type:disc;}
    154154.formulaire_step_actions li {padding:0; border:0; overflow:visible;}
     155.formulaire_step_actions .reponse_formulaire_actions {margin:10px; border:2px solid #FF9933;}
     156.formulaire_step_actions .reponse_formulaire_actions ul {margin:0em 1em;}
    155157
    156158/** roue ajax */
Note: See TracChangeset for help on using the changeset viewer.