Ignore:
Timestamp:
Feb 15, 2014, 1:41:37 PM (6 years ago)
Author:
cedric@…
Message:

mise a jour du lanceur pour utiliser simpletest de tests/

File:
1 edited

Legend:

Unmodified
Added
Removed
  • _core_/branches/spip-3.0/plugins/porte_plume/tests/lanceur_spip.php

    r25050 r80726  
    1111$version_lanceur = '1.0.0';
    1212
    13 if (!defined('_ECRIRE_INC_VERSION')) {
    14         // recherche du loader SPIP.
    15         $deep = 2;
    16         $lanceur ='ecrire/inc_version.php';
    17         $include = '../../'.$lanceur;
    18         while (!defined('_ECRIRE_INC_VERSION') && $deep++ < 6) {
    19                 // attention a pas descendre trop loin tout de meme !
    20                 // plugins/zone/stable/nom/version/tests/ maximum cherche
    21                 $include = '../' . $include;
    22                 if (file_exists($include)) {
    23                         chdir(dirname(dirname($include)));
    24                         require $lanceur;
    25                 }
    26         }       
    27 }
     13$remonte = "../";
     14while (!is_dir($remonte."ecrire"))
     15        $remonte = "../$remonte";
     16require $remonte.'tests/test.inc';
     17
    2818if (!defined('_ECRIRE_INC_VERSION')) {
    2919        die("<strong>Echec :</strong> SPIP ne peut pas etre demarre automatiquement pour le test.<br />
Note: See TracChangeset for help on using the changeset viewer.