Changeset 92362 in spip-zone for _plugins_/tooltip/tooltip_pipelines.php


Ignore:
Timestamp:
Oct 19, 2015, 9:11:23 AM (5 years ago)
Author:
kent1@…
Message:

Ajout d'une version optimisée pour SPIP >= 3.0.0

On ne prend plus en compte IE <= 6

Javascript plus moderne en utilisant la délégation d'évènements

C'est du code à moi donc si ça bug, vous savez à qui vous adresser

Version 1.6.0

File:
1 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/tooltip/tooltip_pipelines.php

    r92315 r92362  
    7171        include_spip('plugins/installer');
    7272        if(!function_exists('spip_version_compare') || spip_version_compare($f('jqueryui','version'),'1.10.1','<')){
    73                 $plugins[] = 'lib/delegate.js';
    74                 $plugins[] = 'lib/dimensions.js';
    75                 $plugins[] = 'js/tooltip.js';
     73                if (spip_version_compare($GLOBALS['spip_version_branche'], '3.0.0alpha', '<')) {
     74                        $plugins[] = 'lib/delegate.js';
     75                        $plugins[] = 'lib/dimensions.js';
     76                        $plugins[] = 'js/tooltip.js';
     77                }
     78                else{
     79                        $plugins[] = 'js/tooltip2.js';
     80                }
    7681        }
    7782        return $plugins;
Note: See TracChangeset for help on using the changeset viewer.